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1. Getting Started with Black Ink
This chapter introduces you to Black Ink
Welcome to Black Ink! In this chapter you will discover the main features of Black Ink 
and how to access crossword puzzles from the Internet.

The Puzzle Window
Black Ink displays each puzzle in its own window, allowing you to work on more than 
one crossword at a time. Each window has the standard title bar, including controls to 
close, minimize, and zoom. The filename of the puzzle is also displayed. The puzzle 
grid occupies the major portion of the window. You navigate within the grid as described 
in the Navigation section. The current clue is displayed above the puzzle grid. When 
open, the clue list drawer is attached to the puzzle window on the left, right or bottom 
edge.
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Opening Puzzles
The first thing you will want to do is get some puzzles to solve. Black Ink makes it a 
snap to download puzzles from the Internet. By default Black Ink displays a web puzzle 
browser dialog when it is first launched. Simply click on a puzzle source and you’ll be 
solving in moments!

At any time you may choose another web puzzle to solve by selecting “Open Web 
Puzzle” from the “File” menu. Both the launch-time browser and the Open menu contain 
all of the puzzle sources configured in Black Ink’s Preferences dialog. If you find another 
source on the Internet, you can use Preferences to add it to the list. Even reorder the list 
to put your favorite puzzles at the top!

If you have existing puzzle files on your computer, simply choose the “Open” item from 
the “File” menu to choose the puzzle file.  Black Ink even provides an “Open as 
Unsolved” menu item in the “File” menu, useful for replaying old puzzles.

Navigation
Black Ink provides a number of ways to navigate within the puzzle. Many of the  
navigation mechanisms are directly affected by user preferences. (See the Preferences  
section of the Configuration chapter for more information.) When a puzzle is opened, 
the first word is selected, usually 1 across. The selected word is always identified by 
highlighting, with the highlight color determined by your system-wide preference. The 
insertion point is identified by a darker shade of the highlight color. The grid itself is 
composed of white and black cells. White cells are active and can contain user typed 
characters. Black cells are inactive and cannot be modified.

Mouse Navigation
Black Ink provides for the use of the mouse for puzzle navigation. A single click 
anywhere within the puzzle grid on an active cell will cause the insertion point to change 
to that cell. If the click occurs within the current insertion point bounds then the 
orientation of the selected word may change. The orientation will not change if a valid 
selection is not possible for that cell in that direction. This is frequently the case in 
cryptic crossword puzzles where only about 25% of the cells are part of both across and 
down words. When the insertion point changes the selected word will also change, 
provided the new insertion point is not a cell within the currently selected word. When 
the selected word changes via this mechanism the orientation will remain the same. 
When the orientation changes the selected word always changes. You can also change 
the insertion point and selected word by selecting a clue from either the across or down 
list in the clue list drawer. The default preferences specify that the insertion point will 
jump to the first empty cell in a word when you select a word from the clue list. See the 
Preferences section for this and other navigation preferences.

Keyboard Navigation
The main mechanism for interacting with the crossword puzzle grid is the keyboard. The 
default action when you type a letter is to fill the current insertion point cell with that 
letter and to move the insertion point to the next empty cell in the word. This movement 
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can be disabled or modified. (See the Preferences section of the Configuration chapter.) 
You can also move the insertion point using the arrow keys. When navigating with arrow 
keys, the selected orientation and word can be changed by alterting the direction of 
movement from horizontal to vertical or vice versa. For example, if the current selection 
is an across word and you press the down arrow key (assuming there is a valid cell 
below the current insertion point), the selection orientation will change to down instead 
of across. By default, the insertion point does not change, but this behavior is also 
controlled by a preference. (See the Preferences section of the Configuration chapter.) 
Arrow key navigation moves the insertion point through inactive cells but is constrained 
by the bounds of the puzzle grid. The tab key or return key can be used to move to the 
next word for the current orientation. The shift-tab key combination will move to the 
previous word for the current orientation.

Direct Word Navigation
Black Ink provides a quick navigation method using the keyboard that allows you to 
jump instantly to any word in the puzzle. By entering the number of the word and 
pressing the Return key the active cell will change to the first cell of the puzzle word 
specified. For example, to move from 1 across to 85 down you would simply enter 85 
and press Return. An overlay containing the digits entered is centered over the 
crossword grid as a visual aid. You can press Escape to cancel a partially entered 
number.

OneAcross.com Lookup
Black Ink makes it easy to search the OneAcross (http://www.oneacross.com/) online 
clue database. The OneAcross system connects clue text to crossword solutions. The 
service is free, with a suggested donation of $20 per year. The “Answer Pattern” 
specifies the number of letters in the word, and any letters that may be in the word 
positionally. For example, if there was a 4 letter word and the middle two letters were 
“NC”, the pattern would be “?NC?”. Black Ink will fill in the clue text, build the pattern 
based on the existing puzzle board contents, and display this in a window. The pattern 
and clue text can be changed before sending a query. When the query is sent, it will 
open your default browser and display the result page. Your browser is used to comply 
with the OneAcross usage guidelines. If you use this functionality regularly, please 
make a donation to OneAcross through their web site.
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Puzzle Timer
Black Ink provides a simple timer for keeping track of how long it takes you to solve a 
puzzle. The amount of time spent on the active puzzle since starting the timer will be 
displayed in the timer window. Switching to a different puzzle will cause the timer 
window to display the amount of time spent on that puzzle since starting the timer. If the 
timer has not been started the Start button will be enabled. If the timer has been started 
the Stop button will be enabled. The Timer window is shown below.

Menus
The menus in Black Ink are a combination of standard application menus and Black Ink-
specific menus. Items of interest are are detailed below.

Black Ink menu
The Black Ink menu is used to access functionality that affects the application as a 
whole. Standard OS X menu items such as Services, Hide, and Quit will not be detailed 
here.

Menu Item Purpose

About Black Ink Displays credits and information about Black Ink.

Purchase Black 
Ink...

Displays information about purchasing and registering 
your evaluation copy of Black Ink.

Check For Up-
date

Checks the Red Sweater Software homepage for Black 
Ink to see if there is a newer version available for 
download.

Preferences… Displays the Preferences window for Black Ink. See the 
Preferences section of the Configuration chapter for 
detailed information.
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File menu
The File menu is used for opening, saving, and printing puzzles.

Menu Item Purpose

Open Web Puz-
zle

A submenu appears with a list of your configured and 
enabled web puzzle sources. Select a source to 
download the latest puzzle and begin working on it.

Open File… Opens a crossword puzzle file. The view will be 
restricted to files ending in the .puz extension.

Open as Un-
solved…

Opens a crossword puzzle file, clearing any previous an-
swers before displaying it. Useful for resolving.

Open Recent Opens a recently opened crossword puzzle file as 
selected from its sub menu. The history can be cleared 
by selecting “Clear Menu.”

Close Closes the active puzzle document.

Save Saves the active puzzle document with its existing name.

Save As… Saves the active puzzle document, after prompting for 
the location and name of the resulting puzzle file.

Revert to Saved Reverts the active puzzle document to its last saved 
state, or its original state if there have been no saves 
since opening.

Page Setup… Provides the ability to modify standard page layout 
settings for the currently active crossword puzzle in 
preparation for printing. Contains Black Ink specific 
printing options. See the “Print Options” section in the 
Configuration chapter for more information.

Print… Prints the active puzzle document, allowing standard 
printer settings to be modified.
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Edit menu
The Edit menu is used to perform a variety of text manipulation actions on the board of 
the active puzzle document.

Menu Item Purpose

Undo Changes the puzzle back to the state just prior to the last 
action. The name of this menu item will be appended 
with text to identify what the action was.

Redo Negates the previous Undo action.

Cut Word Cuts the active word, causing the cells to be emptied 
and the cut text to be added to the system pasteboard.

Copy Word Copies the text of the active word into the system 
pasteboard.

Paste Word Pastes available text from the system pasteboard into 
the active word. If the available text is longer than the 
active word, it will be trimmed before insertion into the 
board. This action will replace any existing text in the 
active word.

Clear Word Clears the active word, causing the cells to be emptied.

Enter Multiple 
Letters

For special puzzles which require multi-letter answers in 
some squares, this menu item facilitates the entry of 
such letters.

View menu
The View menu is used to adjust the appearance of the active puzzle document.

Menu Item Purpose

Show/Hide Clue 
Lists

Toggles the display of the drawer containing the puzzle 
clue lists for Across and Down. The menu name will be 
modified to reflect the effect of selecting it.

Show Puzzle 
Note…

Displays a window containing the text of the puzzle note. 
This menu item will be disabled if there is no note in the 
currently active crossword puzzle.

Show Puzzle 
Timer

Makes the puzzle timer window visible for the active 
puzzle document.
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Solution Menu
The Solution menu contains actions that are related to the puzzle solution, some of 
which are only available if the puzzle is unscrambled.

Menu Item Purpose

Check Current 
Letter

Compares the value at the insertion point cell to the 
correct answer letter. The cell will be modified according 
to the Cell State settings in the Appearance preference.

Check Current 
Word

Performs the same comparison as Check Current letter 
for each cell in the currently active word.

Check Entire 
Puzzle

Performs the same comparison as Check Current letter 
for each cell in the entire puzzle.

Reveal Current 
Letter

Reveals the answer letter of the insertion point cell, 
marks the character as having been revealed. The cell 
will be modified according to the Cell State settings in 
the Appearance preference. Once a letter has been 
revealed it cannot be changed.

Reveal Current 
Word

Performs the same action as Reveal Current letter for all 
the cells in the currently active word.

Reveal Incorrect 
Letters

Reveals the answer letter for any cell in the puzzle which 
is incorrect, marking each revealed character. Once a 
letter has been revealed it cannot be changed.

Reveal Entire 
Puzzle

Reveals the answer letter for all the cells in the puzzle, 
marking each revealed character. The cell will be 
modified according to the Cell State settings in the 
Appearance preference. Once a letter has been revealed 
it cannot be changed.

OneAcross.com 
Lookup…

Displays the OneAcross Lookup sheet, pre-populated 
with the clue and answer text for the selected word. See 
the OneAcross Lookup section above for more 
information.
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Window Menu
The Window menu is used to navigate among the existing windows that belong to Black 
Ink.

Menu Item Purpose

Minimize Window Shrinks the puzzle window and places it in the Dock.

Zoom Toggles the window size between the largest reasonable 
size for the current screen, and the custom size you last 
set the window to.

Web Puzzle 
Chooser

Displays the menu of web puzzle sources available, in 
an easily clickable window.

Bring All to Front Brings all Black Ink windows to the front, above other 
application windows.

Help Menu
The Help menu provides quick access to user documentation and support.

Menu Item Purpose

Black Ink User 
Guide

Displays this document.

Visit Support 
Forums

Opens the Black Ink discussion forum in your default 
web browser.

Send Support 
Request

Opens a new email message in your default email client, 
addressed to the Black Ink Support email address.
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Multi-Letter Cell Input
Some crossword puzzles are created with themes that require multiple letters in a single 
cell. Typing a letter in a cell normally advances the input location to the next cell in the 
word, so to enter multiple letters Black Ink features a separate input mechanism. To 
enter multiple letters, you may either control-click the cell you wish to enter into, or else 
select “Enter Multiple Letters” from the Edit menu.  An enlarged input area will appear, 
allowing the entry of however many letters are needed:

To end editing press the return key. Note that it is possible to press return with an empty 
input area if entering multiple letters was not intended or to delete previously entered 
letters. For puzzles that contain multiple letter cell answers the check and reveal 
functionality will take that information into account.
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2. Configuration
This chapter details the configuration of Black Ink.
Black Ink has many configuration options, allowing a fine-tuned solving experience.

Preferences
Black Ink preferences allow you to customize certain display and behavioral 
characteristics of the application. Preferences are broken into four categories: 
Appearance, Startup, Solving, and Web Puzzles. Selecting Preferences from the Black 
Ink menu will cause the Preferences window to appear.
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Appearance Preferences
Appearance preferences are concerned with visual aspects of Black Ink.

The Cell Status section of the Appearance pane controls the visual feedback Black Ink 
uses to convey information about the way a cell was solved. As you solve, check, or 
reveal puzzle cells, information about the correctness of the cell can be displayed by 
either a small symbol, or by a custom coloring of the answer text. The preview cells on 
the right side of the pane give immediate feedback about how the settings will look while 
solving. 

An “Incorrect” cell is one whose value has been found to be different from the correct 
answer, after being checked with one of the “Check” menu items in the “Solution” menu. 

A “Checked” cell is one whose value has been confirmed as the correct answer, after 
having been previously marked “Incorrect” by one of the “Check” menu items in the 
“Solution” menu. 

A “Revealed” cell is one whose correct value has been supplied by Black Ink, using one 
of the “Reveal” menu items in the “Solution” menu.

The Clue List Drawer section of the Appearance pane is used to change behavior of the 
clue lists. Check the “Opens automatically with window” checkbox if you want the clue 
list drawer to automatically open when a puzzle document is opened. 
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Startup Preferences
Startup preferences deal with the behavior of Black Ink upon launching. Use these set-
tings to adjust the behavior according to your puzzle solving & downloading habits.

The “Open Puzzles On Startup” section includes three options aimed at making it easy 
to start solving as quickly as possible after launching Black Ink. The “Show Web Puzzle 
Chooser dialog” checkbox instructs Black Ink to display a menu of your web puzzle 
choices at launch time. Clicking one of these puzzle sources causes a web puzzle to be 
downloaded and immediately opened for solving.

The “Show Open Files dialog” option instructs Black Ink to display a standard file 
opening dialog at launch time. Using this dialog, you can locate and open a puzzle file 
from your computer’s disk.

Select the “Open most recent puzzle” item if you want Black Ink to try to open the 
puzzle you were last working on, after it finishes launching. 
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Solving Preferences
Solving preferences include options for the puzzle timer, automatic error correction, and 
for adjusting the mechanics of insertion point movement while solving a puzzle.

Select the “Start timer when puzzle opens” option if you want Black Ink to show and 
start the puzzle timer immediately upon opening a puzzle document. See the Timer sec-
tion for more information.

The Insertion Point Movement section is used to control how the insertion point changes 
when various actions occur. The “Move after entering letter” checkbox enables or 
disables the selection of a movement mechanism. If this checkbox is unchecked, the 
insertion point will not change when a letter is typed on the keyboard, requiring you to 
move the insertion point manually. If the checkbox is checked, one of two mechanisms 
will be used to determine how the insertion point moves. The “To next blank in word” 
option causes the insertion point to move to the next blank cell in the word, or simply to 
the next cell if there are no blank cells. If “To next square in word” is selected, the 
selection will always move to the next square in the word, regardless of its contents. 

“Move to blank after switch in direction” causes the insertion point to move to the first 
blank square in a word when the orientation is toggled via a mouse action. The mouse 
actions that qualify are control-click and right mouse click.
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“Move to blank after changing words” causes the insertion point to move to the first 
blank square in a word after you move to a new word using tab, shift-tab, return, or by 
mouse-clicking an item from the clue list.

“Pause on direction switch via arrow keys” defines the behavior when you change the 
orientation by pressing an arrow key. As outlined in the Keyboard Navigation section, 
the selection orientation and selected word can be changed by changing the direction of 
movement from horizontal to vertical or vice versa. When this preference is checked, 
the orientation will toggle, but the insertion point will not change (unless it is necessary 
in order to facilitate an orientation switch). When it is unchecked, the orientation 
changes, and the cursor jumps to the next cell in the word.

“Show incorrect letters as I type them” allows you to be alerted immediately whenever 
you make a mistake in solving a puzzle. This preference is ignored for scrambled 
puzzles. 
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Web Puzzles
Use the Web Puzzles pane to manage your list of puzzle download sources. Checked 
sources appear in both the Web Puzzle Chooser and in the Open Web Puzzle menu.

The sources can be edited in order to change the name, URL, and expected days 
available. Click the “New Source” button to add a source using URL information from 
the web. 

The Web Puzzle downloads folder identifies the area on your disk where newly 
downloaded puzzles are saved. Black Ink organizes the contents of the folder by source 
name so it is easy to browse puzzle files in the Finder. 

When you add or edit a source, a sheet dialog is displayed so that you can enter details 
about the puzzle source:

The Web Source Name appears as the menu item name in the “Open Web Puzzle” 
menu if the source is checked. The Web Source URL is the internet address used to 
download a puzzle. You can specify placeholders for values such as day, month, and 
year as required by the service you are downloading from. The placeholder will be 
replaced with the value for the appropriate date when the source is selected for 
download. A subset of these placeholders is listed below.
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Placeholder Purpose

%d Two digit day, e.g. 02 for the 2nd day of the month

%m Two digit month, e.g. 08 for August

%y Year without century, e.g. 07 for 2007

%Y Year with century, e.g. 2007

The “expect new puzzles” checkboxes should be used to specify which days of the 
week new puzzles are generally made available on. Black Ink uses this information to 
download the most recently published puzzle for any given source. If the source is only 
published on Sunday and you select the source from the “Sources” menu on 
Wednesday then Black Ink will replace the placeholders in the URL with Sunday’s date 
in order to properly download the puzzle.
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Print Options
Black Ink provides support for a variety for printing-related options. These options are 
accessed via the “Page Setup” item in the “File” menu. Select Black Ink from the 
Settings list in the sheet displayed on the puzzle window. You will be presented will the 
view shown below.

The print options are broken into two categories: Ink Saver and Content Options. Ink 
Saver allows you to specify a gray value between Black and Light Gray in which the 
crossword grid will be printed. The closer the slider is positioned to Light Gray, the 
lighter the printed grid will be. Printing a lighter color should reduce the amount of ink 
used to print the grid on paper.

Content Options allows you to choose one of three pre-defined sets of printing content 
or to manually select what content will be printed. Selecting “Playable with current text” 
will print the puzzle grid, letters, numbers, and clues. Selecting “Playable with fresh grid” 
is similar but does not print letters. Selecting “Solution grid” only prints the puzzle grid 
and solution letters. Finally, selecting “Custom” allows manual selection of the content to 
be printed. Note that letters and solution are mutually exclusive. If the puzzle you are 
printing is scrambled, then the solution option will be unavailable.

Black Ink automatically determines if more than one page is required to print all the 
selected content. Generally speaking, puzzles with dimensions greater than 17x17 will 
require two pages if both “Puzzle Grid” and “Clues” are selected.
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3. Black Ink and Spotlight
This chapter explains Black Ink’s integration with Spotlight.
Black Ink provides indexing for puzzle files so Spotlight can be used to find them.

Spotlight Integration
Apple’s Mac OS X 10.4, known as Tiger, includes a system-wide search functionality 
named Spotlight. Spotlight frees you from remembering where files are stored by means 
of a powerful indexing engine. When installed Tiger provides support for many common 
file formats.

Third party applications like Black Ink that utilize special file formats like AcrossLite must 
provide assistance to Spotlight in order to properly index files. Support for Spotlight is 
bundled with Black Ink and you need only run Black Ink once for indexing of crossword 
puzzles to occur. After the initial run any new puzzles will be indexed automatically as 
long as Black Ink is still installed on the computer.

Search Examples
Black Ink provides Spotlight with puzzle title, author, and copyright information. In 
addition all puzzles are identified as being in AcrossLite format. It is possible to perform 
searches using any or all of these items.

Finding All Puzzles
To locate all the crossword puzzles on your computer you can simply enter “AcrossLite” 
(without quotes) into the Spotlight search field.

Finding Puzzles By Author
To locate all the crossword puzzles by a particular author you can simply enter the 
author’s name into the Spotlight search field.

More Information
For more information about Spotlight visit Apple’s website at 
http://www.apple.com/macosx/features/spotlight/ 
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4. Purchasing Black Ink
This chapter explains how to purchase Black Ink.
Black Ink is offered as a free download on a trial evaluation basis. It will operate fully-
functional for 30 days. If you wish to continue using Black Ink, you simply purchase a 
registration code from Red Sweater Software to unlock the evaluation copy of the 
application.

Black Ink will function even past the trial expiration, but will only run for a period of 10 
minutes at a time, and will not allow printing. This gives you the opportunity to continue 
evaluating Black Ink after the evaluation period is over, so you can make your 
purchasing decision. 

When you decide to purchase Black Ink, simply select the “Purchase Black Ink” menu 
item from the main Black Ink application menu. A dialog will appear with further 
instructions.

You may also purchase Black Ink and any other Red Sweater products by visiting the 
Red Sweater Store on the web:

http://www.red-sweater.com/store/
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Apple, the Apple logo, Mac, and Macintosh are trademarks of Apple Computer, Inc., 
registered in the U.S. and other countries. Across Lite is a trademark of Literate 
Software Systems. Black Ink is a trademark of Red Sweater Software. All other 
trademarks, service marks, and trade names belong to their respective owners.

Copyright © 2007, Red Sweater Software.
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