Automatically play a routine at OS X startup
  • Hi,
    first of all I'd like to thank you for your great work, FlexTime is the tool I needed to stop procrastinating on my mac...

    I'd like to know if there's a way to automatically perform these steps at system startup:

    -Open FlexTime
    -Open a predefined Routine (in my case I would like to run the (10+2)*5 anti-procrastination routine) ;)
    -Run the routine
    -Hide the application

    I'm not too expert with applescript and I didn't even tried to do it by myself; I would be great to add these options in FlexTime.
    Thanks for the attention!
    Cheers from Italy
  • Hi - glad you are enjoying FlexTime!

    As for getting it to start at login time there isn't any really easy solution. You can certainly do it with an AppleScript, and I've put together an example of how this might work:

    http://red-sweater.com/flextime/extras/30MinutesReminder.zip

    If you wanted to use this solution for running the script when you log in, for instance:

    1. In the attachment, please double-click the ".zip" file to uncompress a single folder called "30 Minute Reminder".

    2. Copy this folder somewhere on your Mac, e.g. in your Documents folder.

    3. Take a look inside. The folder contains a FlexTime document and a script application that will automatically open FlexTime and start the document running.

    4. The idea is to use the script application "StartupScript" to automatically start the FlexTime processing when you login. So you want to go to your System Preferences under Accounts, and find the login items for your account. Add the "StartupScript" and the next time you login you should find FlexTime automatically launched and starting the routine.

    All of this is unfortunately a bit more complicated than it should be. Maybe in the future I can provide a more streamlined means of achieving this kind of functionality in FlexTime.

    Daniel
  • Thankyou very much.
    I just added
    tell application \"System Events\" to set visible of process \"FlexTime\" to false
    and everything goes fine.
    Keep up the good work!
    Cheers from Italy
  • Thank you!
    This is just what I needed. Sometimes I forget to fire up flextime (which often is the same as forgetting that there writing and work to be done and not internet surfing).

    Cheers from Copenhagen, Denmark
    Nilsson
Start a New Discussion

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!