MarsEdit 1.1.4 not Auto-detect for Old Blogger Blogs
  • I jumped on 1.1.4, as I really wanted to get back to using MarsEdit for Blogger.

    Blogs created using New Blogger auto-detect the settings correctly. Older blogs, created under Old Blogger, then converted to New Blogger, detect as New Blogger, but the RPC settings appear to be the same (or similar) to Old Blogger, so those blogs do not work.

    Is there a guide for manually specifying the New Blogger information? That would be fine for me and get me going again with the Old Blogger-created blogs.

    Again, I am not trying to post to Old Blogger, just blogs that were originally created under Old Blogger, then converted.

    Douglas
  • What I figured out...

    RPC URL /posts/default">http://www.blogger.com/feeds/3/posts/default

    can be found in your Blogger Dashboard

    Reset blog password using File, Enter Weblog Password...

    enter New blogger username and password

    Seems to work so far
  • Thanks, dewelch - this is a test case I didn't have covered. I have one old Blogspot blog (thankfully!) that I could still test against, and I created one new Blogspot blog to test the new API. But I don't want to update my old blog because then I won't have anything to test against for that.

    Can you either post or send me privately the URL of your blog so I can look at it and see how it differs from a "plain new" one?

    Also, I'm curious what happens if you add a new weblog in MarsEdit, and give it your updated URL. Does it figure things out then? I wonder if the problem is in trying to update an existing weblog in MarsEdit.

    Daniel
  • I did try to re-add the blog, as if I was setting it up fresh, and point it at the Old Blogger created, blog, but it auto-updated in the same way.

    Old Blogger created blog, My Word - http://welchwrite.com/blog/

    Auto-updated RPC code gets inserted as: https://www.blogger.com/atom/132777
    instead of the correct code listed above.

    I basically had to go in and manually input the New Blogger URL format, replace the blog id with the appropriate number and then update my password for the blog to my new Google Account.

    I have now posted to all my blogs successfully.

    Douglas
  • Douglas - well I'm really glad that the blogs are now working. But I will definitely do some tinkering with your blog URL and see if I can figure out what's going wrong.

    Thanks !

    Daniel
  • Douglas - the problem seems to stem from that fact that "autodiscovery" info is not up to date for your blog. For example the "service.post" tag inside your blog's home page still points to the old Atom URL you pasted. And the RSD content for your blog is also wrong:

    "http://www.blogger.com/rsd.g?blogID=132777"

    If this stuff doesn't make any sense to you :) - it should make sense to Blogger support. I wonder if this is a general problem for everybody who has been updated? I suggest getting in touch with them and see what they say. Feel free to put them in touch with me support@red-sweater.com.

    It will be a real hassle for people until Google fixes this.

    Daniel
Start a New Discussion

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!