Is there a way to turn off spell-check ... permanently?
  • I never use it, I find it annoying, but I have to turn it off each time I start a new post, by going up into the Edit/Spelling menu. Shouldn't there be a global command in the preferences?
  • Yep - this is fixed in 1.1.6, which is coming soon. I've fixed it so when you turn the spell-check setting on or off in any of the main editor text fields, it will treat that as a preference and restore it whenever you are editing.

    Daniel
  • MarsEdit 1.1.7 is now available, and should fix this!
  • Now the opposite seems to happen, "check spelling while typing" doesn't stay on.
  • Greg: You're running 1.1.7? I just tested it again and it seems to be working. You're turning the setting on while you're in one of the post editing text fields?
  • Now 1.1.8. Just when I think it's turning itself off, it stays on. Can't explain it.
  • I'm not quite sure whether what you're describing means it's still broken, but in a different way, or if you can't explain how it suddenly seems fixed :)
  • I just registered so that I could mention that I'm seeing the same behavior that others are seeing with 1.1.8 - the check spelling feature won't stick. It's keeps turning off. Unlike others here, I'd like it to stay on.

    But either way, it really ought to do as it's told. Grin.
  • Hi Kocab - I'm glad you shared the info. I have to figure out how to reproduce this problem because I am not seeing it.

    Probably, I'm somehow only setting it where I know it should work, so let me clarify the expected behavior:

    -> If the "Check Spelling as I Type" setting is changed while editing any of the main content, extended content, excerpt, or title, of a post, then it should "stick" as the default choice from there on out.

    So it's only set up to work in this specific subset of all the fields.

    There must be a subtle bug here. I will get to the bottom of it somehow :)

    Can I ask kocab what kind of blog system you're configured for? Maybe that has some subtle effect on the setting.
  • Multiple quits and restarts of MarsEdit doest cause it to turn off. Then one day I open up MarsEdit and start a new entry and realize that it's turned off.
  • Are you judging the "offness" by the state of the menu option when it's disabled (not editing a post)?

    What I'm interested in is that the setting is how you like it when you're editing the post.

    Daniel
  • Hi Dan -

    Sorry to have not stuck my head back in here for a while. I've not had the problem of late with "check spelling" turning itself off. Perhaps an update to the system changed something over the past couple of weeks.

    The good news is that I use Mars Edit every day to manage my posting to a number of blogs. It's become one of my "must haves" for OS X. I just noticed the bookmarklet feature too - yay.

    For what it's worth, the problem was on my G4 Tiger 10.4.9 powerbook - all system updates etc applied.
  • Glad to hear it sounds like things are working better for you now!

    Let me know if anything unusual pops up again.

    D
  • Daniel Jalkut said:
    Are you judging the "offness" by the state of the menu option when it's disabled (not editing a post)?

    What I'm interested in is that the setting is how you like it when you're editing the post.

    Daniel

    Both. But i only check the state of the menu item when I've got a entry window open.
  • OK. I guess I'm going to have to revisit this feature and search for weaknesses. It works perfectly the way I use it so I'm not having an easy time pinpointing the problem.
Start a New Discussion

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!