Media Manager unwanted default image size
  • Hi all. Lately I've noticed MarsEdit sort of automatically resizing my images. I say 'sort of' because I don't think ME can actually resize images (can it?). But, when I'm writing a blog post and insert image via the Media Manager, the width entry field always defaults to 600px wide, regardless of what dimensions the actual file has.

    I think is a new behaviour as I've only noticed it on the most recent posts, and I'm certain that past posts have uploaded the image to the WP database at their full image size, i.e., when I clicked an image in the media manager, it automatically displayed it's ACTUAL pixels measurements in the width/height entry fields, whereas now it defaults to 600px wide (and calculates the height proportionally). If I want to upload the image at it's full resolution, I need to change the width/height fields manually.

    When I look at images I've uploaded to WP with ME recently, they are actually 600px wide when right clicked to display only the image in a browser (no HTML), so somewhere something's resizing the image. I'm not sure whether ME can do that, or whether it's passing along size info the the WP database and WP is resizing.

    Is there something I can do to revert this behaviour? Maybe I've inadvertently inserted a 'default' upload size somewhere in ME?

    I've tried removing "com.red-sweater.marsedit.plist" but it made no difference.

    Thanks in advance.
  • Hi - sorry about this. It is in fact MarsEdit resizing the image. It has had the ability to resize the image since 3.0. When you manually change the width/height in the upload utility window, or in the Media Manager window, it's actually instructing MarsEdit to resize the image.

    What's NEW however, is there is a new feature to automatically restrict image sizes to a certain size on a per-weblog basis. i added this in 3.1. This image restriction feature is on by default and is set to … you guessed it … 600px. I did this because I believe the majority of users will find this behavior more appropriate than uploading full-sized images. Especially as images are getting larger and larger, and take a long time to download for readers on slower web connections.

    Not to change the setting back:

    1. Double-click the blog icon in MarsEdit's main window, to open its settings.
    2. Look under "Editing" tab.
    3. Find the setting under "Media Defaults." You want to choose "Defaults to Full Size" from the menu.

    Hope this helps. Sorry for the inconvenience and the unwanted effect on your recent uploads!

    Daniel
  • Hey Daniel.

    That's great, thanks! It is a good feature, I just didn't know how to override it for my needs.

    Cheers
  • Hi,

    Thanks for the explanation, it solved my problem too. I write my blog as an archive for things I find interesting and in the idea that I may use them in the future. So I like to store the biggest image (when the post is related to image) I can find. I'm happy to see it's still possible.

    And thanks for Mars Edit, it makes blogging as chill as Steve McQueen,

    P.
  • Hi,

    I'm new to Mars Edit, and I'm playing around with it. So far, it's great (as I said earlier).

    But let's come back to this image size thing. My personal practice with Wordpress is to upload the biggest image I can find (of a photo, a painting, an illustration, etc.) so I can retrieve an "hi-res" version of it if I want to. However, I'm obviously not displaying the full size image on my blog : the image is constraint to fit my layout (say 600px).

    I've tried to upload a photograph using the "Default full size" setting in Mars Edit. The photo was 700px wide. Here's what happened : 1) A full size image was indeed uploaded to my blog. 2) However whereas I would except the image to be resized to my default setting for publication (600px) the image actually appears to have been horizontally compressed : that is, the aspect ratio is wrong. It's like instead of resizing it while keeping the proportion constant, the image was horizontally compressed.

    I don't have this problem when I create a post directly from Wordpress dashboard.

    I've manually fixed this post, but I surely can reproduce the problem if needed.

    Thanks!

    P.
  • Hi P - sorry about this inconvenience. The media management in MarsEdit is still a bit crude. One issue with WordPress is that even though it creates multiple sized versions of the image, it doesn't offer these different sizes to apps like MarsEdit that upload images to it.

    I think the right solution in the long term is for MarsEdit to take responsibility for creating the multiple sizes itself, and upload each separate image to the blog itself so it can provide the kind of "full size & smaller size" behavior you're describing.

    In the mean time, I am afraid I don't have a great solution.

    Daniel
  • Hi,

    Okay, it confirms what I read on other posts here. It's all right with me. For the moment, I create a draft of my post without the media attached using MarsEdit and then I'll edit those drafts using the Wordpress' dashboard to attach the media I need.

    It's still worth it.

    Thanks,

    P.
  • Odd. Under Preferences-Editing I have no Media Defaults option. Running 3.1.5....has this moved since the post above?
  • An even better option is to set size but maintain the aspect ratio. IE I want to limit my images to 1024 wide but I want to maintain the "look" or aspect ratio of the original. Right now my images appear to be reformated into a square 1024*1024 which mushes the actual photo. Is there a setting I'm missing?
  • Hi ddye - the settings for "constraints" in MarsEdit are maximums in either dimension, so if you want to limit it to 1024 wide, but maintain whatever height of the original, just set the height to something very tall like 9999px. By default MarsEdit will always try to use a proportional resize that gets the size to under the "constraint" for both width and height.
Start a New Discussion

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!