slow from menubar
  • Hi there,

    When I click the FS icon in the menubar, there is a significant delay between the click and the appearance of the script menu, up to 3 seconds. I'm running the latest 2.5 build of FS under 10.6.4 on a 2.5 year old 2.4 GHz MBP. I keep my script folder in my Dropbox, symlinked back to home/library so that I can share the same scripts with my hackintosh running 10.5 (I do not have this problem on the second machine). I've tried replacing the original folder, temporarily deleting the folder and even reinstalling FS, but the problem persists. Hopefully I'm missing something obvious, and am grateful for any ideas. Thanks in advance for your concern.
  • Hi Peter - the slowdown is probably related to either the sheer size (number of files) of the scripts folder, or to the fact that you're using a Dropbox-synced folder for the menu.

    When you said the problem persists even after deleting the folder and reinstalling, do you mean that it happens even if Dropbox is taken out of the equation?

    In any case the slowdown is probably during FastScripts's "automatic script folder synchronization" - this basically just assures that when you add a new file to your script folder, it shows up in FastScripts's menu. You turn off this option in FastScript's preferences, under the "Script Menu" section. If you turn it off, you'll need to quit and restart FastScripts to get it to notice new and removed scripts.

    Daniel
  • Thanks for the reply.

    Actually, I've tried almost everything I can think of, including moving my (12 mb) script folder back to home/library (it's actually an alias, not a symlink), and thus Dropbox doesn't seem like the cause. I've also disabled auto script folder syncing, quitting and restarting after, but this also did not help.

    I'm not sure now whether the problem lies in the severely uncurated state of my scripts folder - not too many scripts, but too many folders (and folders of folders, etc). I've renamed Apple's scripts folder so that they aren't indexed by FS and that (unscientifically) appears to have reduced the click lag. I might clean things up a bit and see whether or not this helps.
  • I'm surprised that turning off the automatic script syncing doesn't help. Sorry I can't think of anything else to try, but do let us know if cleaning up the folder further helps things.

    Daniel
Start a New Discussion

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!