ME 3.2 duplicating image uploads when using plugin
  • Hi,

    I'm still testing Mars Edit for a 'magazine style' photoblog (on a self hosted Wordpress site) and using WP's 'post-thumbnails' feature to create and display a thumbnail image on the main page (index.php) for each post.

    To automate the production of the thumbnail, I use the 'Auto Post Thumbnail' plugin http://wordpress.org/tags/auto-post-thumbnail?forum_id=10 which creates the thumbnail from the first image in the post.

    This works perfectly if I use the login to the WP control panel on the site, but when I use ME, I get duplicates of both the original file and the thumbnail.

    For example: (in the WP Uploads folder)

    test_0001_thru_wordpress.jpg
    test_0001_thru_wordpress-300x240.jpg

    test_0002_thru_marsedit.jpg
    test_0002_thru_marsedit-300x240.jpg
    test_0002_thru_marsedit1.jpg
    test_0002_thru_marsedit1-300x240.jpg

    There is obviously some conflict between the plugin and MarsEdit, but I'm at a loss as to what it could be?

    Confused! 8^.

    Barry


    [Edit to fix link]
  • Hi Barry - I'm not trying to pass the buck, but in situations like this it's extremely likely to be an issue in the plugin, and not in MarsEdit. This is because MarsEdit has very limited access to your blog's media storage (i.e. it has zero access :)).

    When you upload an image with MarsEdit to your blog, it's just requesting to the blog system that it accept the file and save it in the media folder. If it's creating multiple files it has to be an issue on the server side. If it's only happening when this plugin is enabled, then it's probably something to follow up with the plugin developer about.

    Daniel
  • I've had this problem when Wordpress didn't have enough memory to upload an image. Sometimes when you are just on the edge, I had to upload twice and you get two images.

    My _guess_ is that the upload works fine, but then a PHP process that creates the resized image exceeds the memory causes a failure in the XML-RPC process due to insufficient RAM in PHP but the upload has worked just fine.

    I've since changed my wordpress configuration to allocate 64M and now 96M so that I can reliably upload images - in my case, I also run them through smush.it with a plugin to reduce image size.

    Because each hosting provider is a tightwad that hates their customers and give us very little memory space, you may find that allocating memory is tricky so you'll have to work out how to do that yourself.
  • Thanks guys, I'm going to contact the writer of the plugin and see what he can suggest.

    Daniel, I hear you..!! (I just thought I'd try here first!)

    Cheers,

    Barry
Start a New Discussion

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!