Squarespace and Expression Engine Connection Errors
  • I am currently tracking a bug with Squarespace (and Expression Engine, according to comments) where, for a newly configured blog, MarsEdit will receive an "Invalid Website" or "Internal Server Error" upon trying to connect. I have traced the problem to a change in MarsEdit's behavior when a password has not yet been set on the blog.

    To work around the bug in MarsEdit 3.5, select the blog in the main window list, and manually set the username and password on the blog before refreshing again.

    1. Select the blog in the main window.
    2. Select Blog -> Enter Password… from the menu bar.
    3. Enter both username and password in the panel.
    4. Click OK.
    5. Click the Refresh button.

    I aim to fix this in 3.5.1. I'm sorry about the inconvenience in the meantime.

    Daniel
  • Thanks Daniel - this also works for ExpressionEngine too. Glad there is a workaround.
    Cheers - Steven
  • Ah - I didn't realize this was affecting ExpressionEngine too. Thanks for letting me know.
  • well the work around isn't working for me i really hope you fix it soon..
  • John, can you drop me a line support@red-sweater.com with more details about how it's failing for you? If the workaround above doesn't work then it's probably a different issue you are running into, so I'd like to know more about it independent of the fix I've made for the above.

    I also have a beta release of 3.5.1 for you to try if you're interested, to see if it might fix it for you:

    http://red-sweater.com/marsedit/MarsEdit3.5.1b2.zip

    Daniel

Start a New Discussion

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!