Tumblr+MarsEdit: I wrote in Markdown, I sent Markdown, I told it to use Markdown, but now it's HTML
  • I have the same same problem, as it was discussed here http://www.red-sweater.com/forums/discussion/comment/10422,
    but with my tumblr blog.

    I have "Text Filter" under "Server Options" set to "Markdown" in the "Compose" window.

    In the settings for the blog, I have "Preview Defaults - Preview Text Filter" set to "Markdown" and I have "Post Editor - Server Text Filter" set to Markdown.

    When I send the post to Tumble, it ends up as Markdown, but MarsEdit shows it in HTML.

    How do I preserve my lovely Markdown?

    And yep, I use MarsEdit 3.5.3
  • Daniel JalkutDaniel Jalkut
    Accepted Answer
    Hi - generally speaking this should not happen, but is it possible you have MarsEdit set to default to Rich Text editing? if you ever switch into the rich text editor, it will convert any Markdown in your post (assuming it's set to Markdown mode) into regular HTML so it can be edited in the rich editor.
  • Hi Daniel!
    That is it. I've changed this setting to html and everything become normal.
    Thank you!
  • Great to hear! I hope to make this more intuitive in the future.
Start a New Discussion

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!