MarsEdit doesn't post to Blogger
  • i'm having a funny problem- I create posts in MarsEdit and publish them, no error messages. The only problem is that the posts don't show up on my blogger site. I created a new weblog, and when MarsEdit downloaded the existing posts, all of the more recent posts were downloaded, despite never showing on the blog itself. There must be a simple explanation for this, but I can't figure it out. Any help much appreciated!
  • Rajjie: Do you mind telling us the URL of your Blogger blog? I might be able to gather some clues by looking at it. If you'd rather send it to me in private that is fine, too.
  • Here is the blog- http://civilmilitaryrelations.blogspot.com/.

    I also use Marsedit for other blogs, they- funny enough- work fine- e.g. http://securitymanagementinitiative.blogspot.com/

    Thanks for your help
  • Hmm - looks simple enough. So are you saying that if you post something now with MarsEdit, it will not show up on the blog (ahead of "Technical Difficulties"), but that when you refresh in MarsEdit it will be in the list?

    If I've got that right can you do that whole dance and then send me a copy of the "RPC Console" content from the RPC window in MarsEdit? (Window -> RPC Console).

    It might be easier to email it to me support at red-sweater.com.

    This is sounding like a Blogspot display problem. If the items are coming back from the server to MarsEdit, but just not showing up on the web. I'll be able to confirm that from the RPC Console, I think. In the mean time you might also check with Blogspot to see if they can help make sense of it. Thanks!

    Daniel
  • Emailed you the RPC; not sure where to go for help with Blogger.com....
  • Thanks for sending it. I was just about to give up and send a request over to Blogger's API development group, when I realized what's going on. The new items you send from MarsEdit are showing up as "drafts" on your blog.

    MarsEdit isn't specifying this, so it must be some setting on Blogspot. I can't seem to find it though in my settings interface? Do you have any idea where this might be set?

    If nothing else, we know what we need to do. We need to get Blogspot to treat your new posts as non-drafts.

    Daniel
  • Excellent detective work, Daniel. - I think I found the problem- I wondered why I was being required to use word verification to post via the blogger.com interface:

    QUOTE
    Your blog requires word verification

    Blogger's spam-prevention robots have detected that your blog has characteristics of a spam blog. (What is a spam blog?) Since you are an actual person reading this, your blog is probably not a spam blog. Automated spam detection is inherently fuzzy and we sincerely apologise for this false positive.

    Before we can turn off mandatory word verification on your posts we will need to have a human being review your blog and verify that it is not a spam blog. Please fill out the form below to get a review.

    Find out more about how Blogger is fighting spam blogs.
    UNQUOTE
  • Aha! Very interesting indeed. And a good one for the archives in case anybody else comes up with this problem!

    Daniel
  • hey hey!

    i'm having a similar problem with my blogger blog (http://tiboutoo.blogspot.com/) where i cannot post from marsedit. it gives me this error msg:
    Can’t post for i make experiences. because the server reported an error: Please use GoogleLogin or AuthSub.

    User does not have permission to create new post.

    i set my weblog & http passwords to be the blogger passwords. any advice?
    thx.
  • Hi there - don't set the HTTP password unless you're absolutely sure you need it. On Blogspot you shouldn't need it.

    The username and password should be your gmail account at this point. ALL Blogger blogs have been updated to be tied with gmail accounts. If you haven't logged into the web interface for your blog since this switch happened, you may need to do this in order to associate it with a gmail account.

    Finally, make double-sure that the settings are right for the weblog in MarsEdit. Double-click the weblog to open its settings window. Then click the "Auto-Detect Weblog Settings" button.

    Let me know if this helps!

    Daniel
  • sweet! fixed. thanks so much!!!

    btw, i really like marsedit. it is a great product.
  • Great! On both counts :)
Start a New Discussion

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!