I can refresh and download, but I can't post stories...
  • Hi Daniel,

    I can refresh my blog, but I can't post articles due to a 404 not found error.... I have another site that works great using the this theme and plug in set... but this one doesn't want to work... I'm really not sure what or where to look for help

    thanks..

    Doug
    Here's my network log: Network message sent: 2012-09-19 03:20:25 +0000
    URL: http://douglassandquist.com/xmlrpc.php
    Method name: metaWeblog.newPost
    Network reply received: 2012-09-19 03:20:26 +0000
    URL: http://douglassandquist.com/xmlrpc.php
    Method name: metaWeblog.newPost
    Status code: 404
    Succeeded: NO
    --Download Error--
    Request text:
    <?xml version="1.0" encoding="utf-8"?>

    metaWeblog.newPost


    1


    xxxxxxx


    [password]





    mt_tags



    mt_allow_comments
    1


    title
    Test post


    mt_text_more



    mt_allow_pings
    0


    description
    <p>Just testing Mars Edit! </p>
    <p> </p>
    <p>:)</p>


    mt_keywords



    mt_convert_breaks
    0


    mt_excerpt






    0




    Response text:
    <!DOCTYPE HTML>




    Whoops! Page Not Found | Douglas Sandquist DDS
  • Daniel JalkutDaniel Jalkut
    Accepted Answer
    Hi Doug - it's puzzling indeed. The URL in every case is the same: http://douglassandquist.com/xmlrpc.php, so it appears the 404 is being generated within WordPress somehow. I would go through the steps of debugging this by disabling plugins, and possibly switching the theme to something else, and see if you can zero in on it. Maybe one of your plugins is having an interaction specifically with this server.
  • Hi Daniel, I have some time today, so I'll investigate all the plugins and see if I can come up with something... will let you know!
  • Hi Daniel, I deactivated all plug ins and reverted back to a standard theme and still not working... I migrated this blog from Expression Engine to Wordpress. In the Expression Engine version I used quite a few Redirects in my .htaccess file to get rid of the index.php in the url's.. so when i migrated to WP the redirects got stuck in a loop which required me to use a plug in to solve the redirect issue, which it did and is has now been turned off.. but I'm wondering if there something happening on the server side that is returning a 404, not found error... I'm not sure what to ask my host.

    thanks!
  • Daniel JalkutDaniel Jalkut
    Accepted Answer
    Hi there - it seems unlikely that it's something to do with .htaccess redirects, because the URL in question is the same every time MarsEdit communicates with WordPress (it's always a POST to the XMLRPC API URL). It seems like whatever is going wrong must be happening at the PHP level inside WordPress. I'm not sure either what to ask of your server admins except to explain something along the lines of what I've summarized here :) I'm sorry I can't be of more specific help.
  • It's fixed Daniel, I added this line to the .htaccess file

    SecFilterInheritance Off

    I got that from the Wordpress forums. not quite sure why this install was giving me trouble, but it seems to be working fine now..
  • That's great to hear!
Start a New Discussion

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!