Image config when usuing img url
  • I have an old blogger that I host at my own domain. It works with the new blogger settings, I suppose it made it over. The deal is, I couldn't get images to upload via blogger so I decided to upload them via ftp and just create custom img src tags. It works, but....

    I can't get the image to remain within the post area set by blogger. It escapes it and messes up the formatting.
    Here's an example:
    http://phoenixrisingtattoo.hartjoy.com/thornesworld.html
  • Hmm - you mean the way the photo sort of slides down the side of the second post?

    I'm not really an expert at the CSS and HTML formatting issues. I'm pretty sure this is a "problem" with the way the style of the page is set up.

    Maybe if some other forum reader is more of an expert with these matters they could help out. I don't think it's a MarsEdit issue per se, do you?
  • What do you want your image to be placed?

    Add `clear:both;` inside in your CSS theme.

    p.post-footer {
    margin:-.25em 0 0;
    color:#333;
    }

    can becomes

    p.post-footer {
    margin:-.25em 0 0;
    color:#333;
    clear:both;
    }
  • Phew - Takaaki to the rescue :)
  • Thank you for the help!! I gave up and changed my old blogger to new.
    T
  • I'm really new to this -- I used MarsEdit to upload image and text and it showed all was well in preview. In reality, its a mess -- it's on top of last post. It's the default wordpress theme on flightsavorfare.com. The tag line doesn't read correctly either, but I did that thru WordPress. I think. Should I do what you told Thorne to do?
  • Hi nkhayes - again I hope somebody else - maybe Takaaki - will chime in with good advice. But it seems that on your page, the "Short Size" of the default summaries is competing with the larger size of the photos.

    I think the options in that case are to either specify a smaller width/height on the photo, or else change the theme for your blog so that it gives more room to the summaries on the front page (or doesn't show summaries - just shows the whole entry like on www.red-sweater.com/blog).
  • You can save the problem temporarily by adding a style in your entry manually.

    <p style=\"clear: both;\">Residents o..... od Grill Memorial Day weekend.</p>

    You need to learn about CSS as well as HTML if you wanna explore more about this problem. Most of the blog software including WordPress encourage users to separate structures from the contents of the web page.

    If you going to have a better understanding of (X)HTML and CSS, I would hightly suggest you check HTML dog <<a rel="nofollow" target="_blank" href="http://www.htmldog.com/">http://www.htmldog.com/>. Theming a webpage and making a website is no easy task, though starting it is really easy. But as far as I know, you seem to have some knowledge about HTML, which is a great start for your further exploration.

    Hope this helps.
  • It seems, why people start to complain about images not avoiding other elements in Blogger is that, Blogger inserts
    <div style=\"clear:both; padding-bottom:0.25em\"></div>

    at the end of the post if you use the web interface. So, if you use the web interface, the code is inserted, thus making images avoid other elements. On the other hand, in MarsEdit, this code is not inserted, so you see your images appear as you complain.

    You can enable/disable this setting at Setting > Formatting > Enable float alignment .
  • Takaaki: aha! Great work finding this. I am sure this will help a lot of people.

    It sounds like anybody who wants to get the default Blogger behavior can paste the div you show into their posts from MarsEdit.

    At some point I'll make a feature for MarsEdit to allow whatever text to be added on to the posts before they're sent up.
  • That snippet is also the reason why every post has a weird vertical space. I'm not sure if people want the padding-bottom stuff.
Start a New Discussion

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!