Can't upload images
  • Hi there,

    I have a wordpress blog. I downloaded the trial of Mars Edit, but could not get the images to upload. Kept getting an error. Admittedly I deleted the program, but now that TextMate doesn't work version 2.2 of WordPress I'd love to get some sort of dependable blogging software. What is required to be able to upload images to my Wordpress - Uploads folder. Also I love that you support Markdown - will you be adding more supportive features to accommodate markdown lovers like me?

    thanks
    Lou
  • Hi Lou - usually problems with uploading to WordPress blogs has to do with getting the permissions set right on the server.

    If you look in your WordPress Admin panel on the web server, you'll find the upload path in "Options" -> "Miscellaneous"

    This configures where WordPress will attempt to put files that are uploaded via MarsEdit. This directory must be writable by your webserver. Specifically, it must be writable by PHP, which is the software that WordPress is implemented in.

    Unfortunately making the folder writable varies greatly from system to system. It depends on how your host has set up your ability to write files from your web site.

    If you aren't sure, the best bet is to ask your hosting provider. Look in the WordPress settings to find the exact path, and then send a message to your hosting provider with something like:

    "I would like to enable PHP to have write-access to this folder in my web site: "blog/wp-content/downloads". Can you either enable this for for me or tell me how I can configure it to be writable by PHP?"

    If the writability of the directory is not the problem, then it will help me to see what the error message MarsEdit gives when attempting to upload the file.

    Hope this helps,
    Daniel
  • Hi Daniel,

    Thanks for the speedy reply. Hate to be the bearer of bad news, but all my permissions are set properly. That was the first thing I checked. The upload feature in TextMate worked great. And I put the path into MarsEdit as indicated by Options > Miscellaneous.

    But before I waste your time, let me download the MarsEdit again and give it another try so I can give you the exact error message.

    Lou
  • So I had the "Organize my uploads into month- and year-based folders" checked before. Maybe that did not fly with MarsEdit. Now that I have it unchecked, everything works great. So great that I just made the purchase.

    thanks
    Lou
  • Excellent! The "path" field is a bit misleading, actually. Generally you want to leave that blank with WordPress because it has its own organization system and doesn't really respect that field the way you'd think it would.
Start a New Discussion

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!