Blogger issue with "Invalid Blog ID"
  • Unfortunately something changed recently with Blogger and auto-configuration is no longer working as expected. I am working on a fix for the next update to MarsEdit, but in the mean time you can manually fix the settings in MarsEdit to address the problem:

    To open the blog settings in MarsEdit, open the Main Window, and find your blog in the list on the left side of the window. Double-click the blog icon to open the settings window. Then change the "API Endpoint URL" setting and "Blog ID" setting for your blog to:

    API Endpoint URL: http://www.blogger.com/feeds/[YourBlogID]/posts/default
    Blog ID: [YourBlogID]

    In this case because your blog has already been setup with "the wrong" ID, the [YourBlogID] part in the settings above should be the numeric part BEFORE the & in the existing setting. E.g. if the blog settings were currently:

    http://www.blogger.com/feeds/12345&zx=2354aa7f-a08a-482f-bcc5-ad78f0934e8e/posts/default

    and

    12345&zx=2354aa7f-a08a-482f-bcc5-ad78f0934e8e

    Then you would want to change them to just:

    http://www.blogger.com/feeds/12345/posts/default

    and

    12345

    (Obviously, make sure to use the right number for [YourBlogID]).

    Click OK and then "Refresh" the blog. It should work correctly now.

    Daniel
  • Lifesaver. Thank you!!!
  • FYI folks this was fixed permanently (I hope!) in the 3.6 release of MarsEdit. It is available now on the Red Sweater home page and should be available soon on the Mac App Store after Apple approves the changes.
Start a New Discussion

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!