Trouble Posting to Blogger (NEW)
  • I am using the new blogger with the google login. I am unable to post successfully with MarsEdit 1.2.1. Please help. Thanks. Here is my RPC Console log:

    RPC message sent: 2007-08-01 16:15:15 -0500
    URL: https://www.google.com/accounts/ClientLogin
    Method name: Google ClientLogin Authentication
    RPC reply received: 2007-08-01 16:15:17 -0500
    URL: https://www.google.com/accounts/ClientLogin
    Method name: Google ClientLogin Authentication
    Status code: 200
    Succeeded: YES
    Response text:
    [Google authentication information hidden for security protection]

    RPC message sent: 2007-08-01 16:15:17 -0500
    URL: http://www.blogger.com/api
    Method name: POST
    RPC reply received: 2007-08-01 16:15:18 -0500
    URL: http://www.blogger.com/api
    Method name: POST
    Status code: 200
    Succeeded: YES
    Request text:
    <?xml version="1.0" encoding="UTF-8" standalone="yes"?>



    MarsEdit


    Response text:
    <?xml version="1.0" encoding="UTF-8"?>faultStringcom.google.blogger.b2.api.NoSuchApiMethodException: blogger.getUsersBlogs([])faultCode0

    RPC message sent: 2007-08-01 16:15:18 -0500
    URL: https://www.google.com/accounts/ClientLogin
    Method name: Google ClientLogin Authentication
    RPC reply received: 2007-08-01 16:15:18 -0500
    URL: https://www.google.com/accounts/ClientLogin
    Method name: Google ClientLogin Authentication
    Status code: 200
    Succeeded: YES
    Response text:
    [Google authentication information hidden for security protection]

    RPC message sent: 2007-08-01 16:15:18 -0500
    URL: (null)
    Method name: GET
    RPC reply received: 2007-08-01 16:15:18 -0500
    URL: (null)
    Method name: GET
    Status code: 0
    Succeeded: NO
    --Fault Error--
    Fault code: 0
    Fault string: bad URL
    Response text:
  • Hi there - it looks like your authentication is succeeding, but the RPC URL for the blog is set wrong. Is this a Blogger with a custom template? The auto-detection tags in the blog may not have the correct RPC URL, which should look something like this:

    http://www.blogger.com/feeds/2742621948488638421/posts/default

    Where the number is particular to your blog.

    You may be able to fix this by just clicking the "Auto-Detect Weblog Settings" button again from the weblog settings dialog. If that doesn't work (if it still shows http://www.blogger.com/api as the RPC URL), then you may need to either manually configure the weblog, or fix your weblog template to advertise the correct auto-detection information.

    Blogger has a section in their template documentation that talks about the <$BlogMetaData$> tag, which you can put in your theme in the header, to advertise the correct information:

    http://help.blogger.com/bin/answer.py?answer=42095

    Let me know if all this helps :) I'm pretty sure that's the problem.

    Daniel
  • Thanks, I think this has me all fixed up. It is working for now. I added the Blog Meta data tag and it auto-detected the URL. Now I hope it will continue to work. I love using MarsEdit and had been neglecting my blog for a while because of my posting problems.
  • Great! A lot of Blogger people are having this problem since they changed the URL format but there's no way for them to change the "auto-detect" info in all the external users' blogs.
Start a New Discussion

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!