http links on https-endpoint
  • My WP install uses http, but the admin-area uses https. In the settings-window in MarsEdit, I have configured things accordingly: Homepage URL starts with http, API Endpoint URL with https.

    Now whenever I post with MarsEdit, things are going well, except that the links to my entries, which the Jetpack-plugin publishes to Facebook, Twitter, and other services begins with https: This causes problems as I, eg, do not load CSS and other external references via https.

    When posting directly from within WP, the Jetpack-published links are (correctly) beginning with http.
  • Hmm, interesting case. I'll have to take a closer look at it. But since the Jetpack plugin is responsible for generating the links, I would guess this is an issue in Jetpack and/or WordPress itself, not something that MarsEdit can address.

    I'm guessing if you connected to WordPress from another API client such as e.g. the free iOS WordPress app, you would see the same behavior.
  • Okay, then I will look into it, too!
  • Hi there - I finally got a chance to install Jetpack and tried to get it set up similar to you but unfortunately I'm having trouble getting it to show the "Publicize" stuff. When I go to the Jetpack console it lists the Publicize as an option but there's no way to "Activate" it. Any tips for me?
  • Same problem here. In my case it was a caching plugin's minify-engine that made this impossible somehow.
  • Hmm - so maybe I need to disable other plugins to get it going huh? I'll give that a try. Thanks!
Start a New Discussion

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!