Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Image preview not working

This is a very strange problem. I've been using ME without issues for some time. This morning, I went to write a post as I normally do. I uploaded an image to my server, and then I added the code for that image to the post. A blue question mark shows up in the preview area. I copied & pasted the URL into a browser, and the image appears there just fine. I then tried using a URL for a previous image I had uploaded to my server for another post. It displays in the preview window in ME without a problem. I tried several other images already on the server, also no problem. So then I uploaded another version of the image that won't preview. And it still doesn't preview. It seems that the preview won't work with any image that I have uploaded to my server today. Any ideas?


  • Hi - this does seem pretty weird. What it sounds like to me is a "caching" issue with WebKit, the browser technology from Apple that MarsEdit also uses.

    Unfortunately it is not always straightforward to find out where WebKit is caching stuff. The first place I would look is:

    [Home] -> Library -> Caches ->

    Look for something like "" in there, and throw it out. If you then relaunch MarsEdit, do the images start to work again?

  • I think you're right about WebKit, because I'm also having trouble logging into the Wordpress admin panel on my domain. But get this - the problem only occurs with Safari! I have no trouble logging in with Firefox or Chrome. I also can't access the domain using the Wordpress iPhone app, which I believe is based on WebKit too.

    I've cleared internet caches using Cocktail and flushed the DNS cache in Terminal; I also threw out the Safari and ME cache in Library > Caches, but so far the problem remains.

    This is really weird.
  • Is it possible the site in question is behind a HTTPS secure server?
  • Great question. One of them is a dedicated IP with HTTPS. But the other does not. It's notable that the only problems I'm having are with Wordpress sites - whether accessing them through Safari, MarsEdit or the Wordpress iPhone app.
  • The reason I asked is because Safari, and the networking infrastructure that WordPress's iOS app, for that matter, is a little pickier about HTTPS security certificates than some browsers are. Would you mind pasting a URL for one of the images in question that won't load? I am curious to test it out on my Mac and see if it will load.

    Another thing that comes to mind is whether it's possible that your site has some kind of security provision preventing "other sites" from loading images from them. That might cause the images to not show up in MarsEdit, too.
  • Thanks, Daniel. Before I do that... I have no trouble accessing the WP sites using Safari on my Macbook, so that tells me the issue is not with Safari per se but with Safari specifically on my Mac Pro. And it's not a problem in my user account, because I experience the same issue with Safari in my wife's account. Do you know if there is a WebKit cache at the system level that would effect both Safari and MarsEdit?

    Then again, I am having the problem on the Wordpress iPhone app as well - which means it may extend beyond my Mac Pro. The error I'm getting there is "HTTP/1.1 404 Not Found".

    I just tried adding an image to ME and it seems to be working now.
  • Looks like I spoke too soon. Here's what happened: I uploaded the image to my server, then pasted the link to it in a new ME post window. It showed up in the preview immediately. However, about a minute later, the image disappeared and it was replaced with a "blue question mark". Here's the link to the image:
  • edited July 2011
    After it disappeared in MarsEdit, can you still load the image in Safari? I am testing it in my copy of MarsEdit now, and will let it sit for a while. So far it is working, hopefully I'll see the blue question mark soon :)
  • Well, the plot thickens. Now I am getting an error message when attempting to submit a new post in ME. The error is:

    "Can’t post for The Healthy Skeptic because the server reported an error: unexpected response code 504."

    I cannot load the image in Safari. Nor can I load it in any other browser, in fact.

    Hmmm. Appears my server might be down. No idea if this is all related.
  • Hmm. Certainly seems like it could be related. We should definitely wait to do more testing until the server is stable again.
  • The server is working now. But I still see the blue question mark in ME. You?
  • Hmm, no it seems to work for me. Is it a blue question mark in Safari, too, or just ME?

    If you load the test page I just published, linking to the same photo, does it show a blue question mark in Safari, too?

    If it's just in MarsEdit alone that the blue question mark ever happens, then it does sound like the WebKit cache for MarsEdit has somehow gotten screwed up and now contains a blank cache image or something for the given URL.

    What if you change the URL for the image to:

    I wonder if this "unique" URL (which happens to return the same image) will load correctly, revealing the likelihood of a caching issue in MarsEdit.

  • I can see the image in Safari on your test page.

    I changed the URL in ME to the "?test" and it still shows the blue question mark.
  • What the heck. Thanks for your patience, while I try to figure this out. And just to make sure we're on the same page, if you copy the image URL from MarsEdit to Safari, and load it, you can see it there directly, too?

    I.e. if we focus just on the image problem, is it only happening in MarsEdit?

    Could you copy/paste the entire HTML source from MarsEdit and maybe email it to me? I want to see if I load it up exactly like you have it, if I see any different behavior.

Sign In or Register to comment.