Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Marsedit not completely fullscreen on Mavericks?

edited January 2014 in MarsEdit

There's a black bar at the top and bottom of my edit window. I'm using a 2010 13" Macbook Pro. Is this intentional behaviour?



  • Hi Vincent - sorry about this change of behavior. It's an intentional change I made in MarsEdit 3.6.3 because I noticed the way Apple animated the window to full screen height, it would sometimes end up a few pixels off. I thought it was more desirable to have the window have a significant margin but maybe the old behavior is better?
  • Hi Daniel, it looks a bit weird this way, so my preference is is a true fullscreen. But it's not a deal breaker by any means :)
  • Thanks, Vincent. I am going to keep refining the full screen experience as I move forward. I'll take another look at it for the next update!
  • I am joining the Topic - because still no progress

    It's a late 2011 MBPro 15", running 10.9.3 (res: 1680x1050) Please let me know I you need a BetaTester.
  • Hi Espresso - thanks for chiming in. I'm not really sure what the best thing to do is. Possibly I should allow the full screen window to be adjusted even in full-screen. The problem is some people seem to like it not taking up the "full screen" (they just like the focus and being undistracted).
  • Hi Daniel,

    I see your point and understand it's not easy to decide. But ... FullScreen means FullScreen. People who don't like this, should rather use maximized Window. IMHO that's why Apple kept them.

    Don't you think, visible grey bars are more distracting than an editor, which completely fits the entire Screen? You could consider to give the User the Option to use real Full-Screen (Editor fits the entire Screen) or not. Have you ever used DFW (Distraction Free Writing) If not give free a try. To be honest, everything would be better that those grey bars. (no offense)

    Beside of that, my inside Monk goes nuts having these very grey bars on top and below of the Editor Window. :)
  • Thanks for the feedback. I think probably your issue boils down to the window frames in MarsEdit and not so much about the text being limited to a smaller space on the screen. I haven't looked at FocusWriter yet, but I will. I'm guessing though that even if it "takes up the whole screen" it still keeps the text limited to some relatively smaller portion of the screen?
  • I believe DFW is the wrong way for an BlogEditor, especially if you going to add Links, Pictures etc. You always need to leave this mode and do something with something else. Disturbing.

    Maybe you're right, my Issue is just about those two bars. Haven't seen it that way.

    However, IMHO the current Working-Area and the relations (not sure if this is the right word) between them are fine. Like in this mokeup the Editor-Windows would be almost perfect:
  • Thanks - I do plan to iterate on this and try to improve the layout but I can't make any promises about it happening super soon.
  • I was heading to this Forum to see what I can do to resolve this. Talking to you directly was actually more than I was expecting in the first place. Please let me know if you think I could be helpful to move things forward.
  • Thanks! I think what I'll plan to do is if I have a beta release at some point with improvements, I'll post it here first to get your feedback (and others, if interested). So if it's easy to keep subscribed to email notifications for this topic (is it, I'm afraid I can't remember :) ) then that would be one way to stay in the loop about possible updates.
  • already faved, waiting for your 'call'.
Sign In or Register to comment.