CMD+W
  • Hi There,

    I'm not quite sure what I've done, and therefore not quite sure how to fix the situation.

    For some reason, my CMD+W keyboard shortcut has been re-routed from closing windows to opening my FastScripts' menu. Where do I look to change it back?

    Thanks!

    Pat Dryburgh
  • Hi Pat - you can set a keyboard shortcut for the menu, in the FastScripts preferences dialog:

    1. Click the FastScripts icon in the menu bar.
    2. Select the FastScripts sub-menu.
    3. Select Preferences.
    4. Click the "Script Menu" tab.

    You'll see a preference in there for changing the shortcut. The standard setting is Cmd-Opt-Shift-]

    Probably what happened is you ended up in Preferences with this field selected, and then pressed Cmd-W to close the Preferences window, unaware that you were actually setting the menu shortcut.

    Daniel
  • Hey Daniel,

    That's what the problem was.

    The issue is actual a UI issue. As soon as a user opens the preference window, the box to select a keyboard shortcut is automatically filled in, meaning that anything the user types before noticing the input box is active is recorded. In my case, I clicked "CMD+W" to close the preference window, probably wondered why it didn't close, and closed it by clicking the "x" before realizing what I had done.

    I would suggest checking out how Droplr handles this in their Shortcuts pane in their preference window. It is very well thought out, and the animations they've included make it incredibly clear what is happening with that UI.

    Hope that helps with future versions of FastScripts!

    Cheers,
    Pat
  • I agree this is problematic. Thanks for the suggestion of Droplr, I'll check out how they solve it.

    Daniel
Start a New Discussion

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!