Trouble with Markdown
  • While working on my new site I figured I'd try a quick post to it from MarsEdit using Markdown. I've already got the Markdown plugin installed for WordPress and in fact the post looks fine on the blog. The trouble is seeing it in MarsEdit. On the Preview window if I attempt to change the Markdown it snaps back to None or Converting Line Breaks (whichever was previously selected). I see Markdown for a split second. I changed the Defaults for the blog so that the Preview Text Filter is Markdown and this causes it to work, but now if I try to change the Formatting choice in the Preview window it snaps back to Markdown :) Its not really a big deal, but it does seem like an odd UI convention. Why let me interact with the popup if I can't actually change it. The important thing of course is that I could send the post to WordPress and it worked!
  • Thanks Stephan I will have to spend some time investigating this to see if I get the same problem. I'll let you know if I uncover anything interesting - and if there's a bug I'll definitely add it to the fix list.

    I'm glad the post worked at least :)

    Daniel
  • Im seeing the same problem on a very simple short post.

    the preview is initially not in markdown, then i change the dropdown menu, it updates the preview accordingly but the dropdown reverts to "none"

    then if i focus on another window and come back, the preview reverts to plain text (it naturally uses what's currently selected in the dropdown menu but my choice didnt stick)

    This is with the latest version i just downloaded a few minutes ago btw

    Thanks
  • Thanks Bruno now that I've had a few days to get acquainted with the sources I feel more comfortable attacking the problem. I'll see what I can find.
Start a New Discussion

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!